B. L. O. G.
Belangrijke Literatuur, Onze Gezelligheid

 

Verouderde Joomla versies lek

Een groot gedeelte van de websites welke online gehost worden, worden onderhouden met een CMS, oftewel een Content Management System. Deze CMS-en zijn er veel, allemaal met hun eigen mogelijkheden, plus- en minpunten en aanhang. Eén van de eerste en grootschalig gebruikte CMS-en is Joomla. De eerste stabiele versies verschenen al ruim tien jaar geleden, en in tien jaar tijd hebben de ontwikkelaars natuurlijk niet stil gezeten. Inmiddels zijn ze al bij versie 3.3 en zal de lancering van de 'long term support' versie 3.5 niet lang op zich laten wachten.

Het nadeel van deze ontwikkelingen is, dat u uw website zelf geregeld dient te updaten. Juist omdat het zo'n populair systeem is, zijn hackers actief op zoek naar lekken in de gebruikte software. Deze lekken worden door de ontwikkelaars van Joomla dan in een nieuwe versie gedicht. Maar u zult dan wel even handmatig moeten updaten, wilt u van de nieuwe, veiligere versie gebruik wensen te maken.

Voert u niet regelmatig updates uit, loopt u het risico dat uw website misbruikt gaat worden voor uitgaande aanvallen op financiële en officiële instanties, spamverzending en het verspreiden van virussen op het internet. Hiervoor worden er dan scripts geplaatst in verschillende mappen binnen uw public_html. Dit probleem wordt dus veroorzaakt door de verouderde Joomla software waar uw website mee werkt of een plug-in die u hier op aansluit. In de meeste gevallen is uw website niet meer te herstellen naar een veilige staat en is de enige oplossing dan u een nieuwe website maakt of laat maken.

Versies waarmee u een erg groot risico loopt om gehackt te worden (of reeds bent) zijn Joomla 1.5, 1.6 en 1.7. Joomla 2.5-versies zijn veiliger, maar ook daarin zijn al lekken bekend. Indien u gebruik maakt van Joomla 1.5, 1.6 of 1.7 kunt u niet of slechts beperkt upgraden naar Joomla 2.5. Een compleet nieuwe website zal dan vaak rendabeler zijn. Indien u reeds werkt met Joomla 2.5 kunt u gemakkelijk updaten naar de laatste stabiele versie van de 2.5-branche, wat op het moment van schrijven Joomla 2.5.19 is. Weet u niet welke versie van Joomla u gebruikt? Dit vindt u vaak terug wanneer u ingelogd bent in uw Administrator-pagina of in uw bestanden. Kunt u het daar niet vinden, neemt u dan contact op met onze helpdesk. wij zoeken dit graag voor u uit.

Voor het draaien van de nieuwe of nieuwste versies van Joomla, heeft u wellicht ook een nieuwere versie van PHP nodig. Wilt u upgraden maar krijgt u een foutmelding dat de server ontoereikend is, verhuizen wij uw pakket kostenloos naar onze nieuwste hostingserver. Meer informatie hierover kunt u ook verkrijgen via onze helpdesk. Deze benadert u telefonisch via 040 235 9290 of per ticketsysteem op https://cp.flexwebhosting.nl