B. L. O. G.
Belangrijke Literatuur, Onze Gezelligheid

 

Beveiliging PHPMailer

Afgelopen december werd bekend dat er een lek in PHPMailer was geslopen, waardoor onbekenden de scripts konden misbruiken om SPAM e-mail mee te verzenden. Dit werd bekend onder CVE-2016-10033

PHPMailer is een bekend en wijd gebruikt script om het verzenden van e-mails vanuit websites, bijvoorbeeld contactformulieren of bestel-bevestigingen, gemakkelijk mogelijk te maken. Waar het begon als een op zichzelf staand iets, werd het gemak al vlot gesignaleerd door andere ontwikkelaars en werd het script binnen een mum van tijd de standaard in grote CMSsen, zoals WordPress en Joomla.

In versie 5.2.18 werd het probleem in eerste instantie ontdekt en gedicht, waarna bleek dat er toch nog iets gemist was en uiteindelijk versie 5.2.20 als veilig werd verklaard. De ontwikkelaars van CMSsen importeerden de nieuwe versie in hun platform en de wereld werd weer een stukje spam-vrijer.

Helaas komen we op ons hostingplatform nog geregeld verouderde versies tegen, zelfs zo ver terug als 2.0.6. Vaak zijn dit oude, vergeten back-ups of testversies van websites, welke nooit meer worden geüpgraden. 

Om ons platform te beschermen tegen verdere spamverzending en te voorkomen dat u als klant hier hinder van ondervindt doordat onze servers een slechte reputatie krijgen, zullen we vanaf vandaag alle versies van PHPMailer lager dan 5.2.20 blokkeren

Ondervindt u problemen met het versturen van mails vanuit uw website? Dan kan dit de reden zijn. Neem contact op met onze collega's van de TD om dit vast te stellen. Als het inderdaad zo is, kunt u uw website of de gebruikte PHPMailer library updaten om zo weer volledig gebruik te kunnen maken van de functionaliteit hiervan.