B. L. O. G.
Belangrijke Literatuur, Onze Gezelligheid

 

De IT-wereld verbetert, en wij gaan mee

Zoals u weet, is de IT-wereld constant in beweging. Nieuwe technieken worden ontwikkeld, software wordt beter, alles gaat sneller en groter. Bekende CMS-en als WordPress en Joomla komen regelmatig met nieuwe versies, waarbij ook hogere versies van PHP en MySQL vereist worden.

Zoals u weet, zullen wij niet zomaar kritieke onderdelen van een server upgraden. Denk hierbij aan bijvoorbeeld de geïnstalleerde versies van PHP of MySQL. Dit kan namelijk problemen opleveren voor uw websites. Wanneer we een nieuwe server aan ons serverpark toevoegen, gebeurt dit uiteraard wel met de nieuwste versies van software en op recente hardware.

Vanwege de toenemende onveiligheid in verouderde software, het niet meer beschikbaar komen van patches voor kritieke software onderdelen en de toenemende aanvallen op die software, zullen wij vanaf begin 2015 ons gehele hostingpark gaan upgraden naar nieuwe servers met nieuwe software. Dit komt niet alleen de performance van de server en uw websites ten goede, maar natuurlijk ook de veiligheid voor uzelf en uw bezoekers of klanten.

We zullen deze upgrades gefaseerd uit gaan voeren. Een aantal van onze resellers zijn inmiddels bezig met het overzetten van hun klanten naar nieuwe servers. Deze servers draaien met de laatste stabiele versie van PHP 5.5, MySQL 5.6 en Apache. PHP 5.6 is op dit moment nog te nieuw voor ons om volledig in productie te nemen, mede omdat ook DirectAdmin (het door ons gebruikte controlepaneel) hier nog geen support voor heeft.

In de loop van dit jaar of begin volgend jaar zal het grootste gedeelte van onze klanten bericht krijgen over een overstap naar een nieuwe server. Hierbij zullen alle hostingpakketten die nog niet op een PHP 5.4 of PHP 5.5 server gehost worden, door ons overgezet worden naar een PHP 5.5 server.

Wat betekent dit voor u?

In principe merkt u van de overgang niets. In de meeste gevallen zal bijvoorbeeld zelfs het IP-adres ongewijzigd blijven, dit wordt dan gewoon meegenomen naar de nieuwe server. Waar deze overstap echter wel een rol gaat spelen, is bij websites die lange tijd al niet meer geüpdatet zijn.

Maakt u nog gebruik van een verouderde versie van WordPress, Joomla, Drupal of een ander CMS? Lees dan verder voor meer informatie, omdat er voor u dan misschien wel iets gaat gebeuren wat aandacht vereist.

PHP foutmeldingen

Omdat u naar een nieuwe server verhuist, kan het voorkomen dat uw website foutmeldingen gaat vertonen. Vooral als u gebruik maakt van (verouderde) versies van op PHP gebaseerde Content Management Systemen (denk aan Joomla, WordPress of Drupal), zal dit voor gaan komen. Maar ook als u zelf in PHP heeft geprogrammeerd, kunt u op dat moment gebruik gemaakt hebben van functies die ondertussen niet meer actief zijn.

Voor een overzicht van alle wijzigingen in nieuwere versies van PHP, kunt het beste terecht bij de PHP documentatie zelf. Deze vindt u op de volgende URL: http://php.net/manual/en/migration55.changes.php

Vooral de deprecated functies zullen zichtbaar gaan worden. Een overzicht van de verschillende functies die per versie vervallen zijn, vindt u hier:

Foutmeldingen uitschakelen

Deprecated foutmeldingen zijn vervelend en ze zien er lelijk uit. Maar, feitelijk geven ze alleen maar aan dat een functie in de toekomst zal gaan verdwijnen. Op dit moment is die functie gewoon nog bruikbaar.

Indien u een deprecated foutmelding te zien krijgt, kunt u er dus voor kiezen om deze te negeren en verbergen. Dit is niet aan te raden, maar zou voor op de korte termijn een mogelijkheid zijn. Wilt u dit doen, kunt u hiervoor een .htaccess-bestand aanmaken (of het huidige aanpassen) in de public_html van de website. Hier neemt u dan de volgende regels in op:

php_flag display_errors off
php_value error_reporting -1

Hierdoor zullen de foutmeldingen verdwijnen. Houd er wel rekening mee dat de problemen zelf nog niet opgelost zullen zijn, en dat deze dus nog steeds opgelost dienen te worden!

Joomla is sinds enkele jaren een bekend CMS (Content Management System). Sinds versie 1.5 zijn vele tienduizenden website met dit systeem gemaakt. Helaas waren de ontwikkelaars hier niet op voorbereid, en was het updaten naar een nieuwe versie erg lastig, zo niet onmogelijk.

Hierdoor zwerven er vandaag te dag nog ontzettend veel oude Joomla websites rond. Deze zijn ondertussen erg vatbaar voor virussen, spamaanvallen en andere hacks. Upgraden is helaas geen optie, een gemakkelijke manier om een dergelijke Joomla 1.5 site te upgraden naar de huidige versie 3.3.x bestaat simpelweg niet.

Maken uw websites gebruik van Joomla 1.5? Er zit dan helaas niets anders op om deze opnieuw op te bouwen.

WordPress

Bent u op zoek naar een nieuw CMS om mee te beginnen, waarbij u bijvoorbeeld gemakkelijk pagina's aan kunt maken of kunt wijzigen? Kijk dan eens naar WordPress.

Ooit begonnen als een CMS gericht op bloggers, is WordPress inmiddels uitgegroeid tot een volwaardig Content Management Systeem. Met vele thema's, plug-ins en handleidingen op het internet, is het een erg populair systeem. WordPress kunt u gratis downloaden via http://www.wordpress.org of installeren via Installatron. Op ons blog hebben we een tweetal artikelen over 'Beginnen met WordPress'. Deze vindt u op de volgende URLs:

Meteen aan de slag?

Wilt u niet op ons wachten, maar direct aan de slag op een nieuwe server? Dat kan natuurlijk ook! Laat het ons per e-mail naar sales@flexwebhosting.nl of ticket via uw klantenpagina weten. Wij verhuizen uw pakket dan alvast naar een nieuwe server, zodat u direct gebruik kunt gaan maken van de nieuwste versies en de nieuwste software!